summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartijn van Beurden <mvanb1@gmail.com>2022-04-19 19:37:09 +0200
committerMartijn van Beurden <mvanb1@gmail.com>2022-04-20 11:10:08 +0200
commit0f98b940f851963e90ae062e18ba06034b0698e5 (patch)
tree2f1feeefb79f123ada6635545355f526a08ec7a4 /configure.ac
parentb48ed95fcbf2cd4e32317acd297663d3d6519e37 (diff)
downloadflac-0f98b940f851963e90ae062e18ba06034b0698e5.tar.gz
Update fuzzers
This changes the names of the two fuzzers so they align with current oss-fuzz usage (to provide continuity in test data and corpora) and adds a dictionary to the decoder fuzzer. It also removes some unnecessary configuration, as it clashed with oss-fuzz defaults
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 52b3ce04..7f3bfc20 100644
--- a/configure.ac
+++ b/configure.ac
@@ -382,15 +382,13 @@ if test "x$have_oss_fuzzers" = "xyes"; then
else
AM_CONDITIONAL([USE_OSSFUZZERS], [test "false" = "true"])
# Disable fuzzer if the compiler is not Clang.
- AC_MSG_WARN([*** Ozz-Fuzz is disabled because that requres the Clang compiler.])
- have_oss_fuzzers="no (compiler is GCC)"
+ AC_MSG_WARN([*** Ozz-Fuzz is disabled because that requires the Clang compiler.])
+ have_oss_fuzzers="no (compiler is not Clang)"
fi
else
AM_CONDITIONAL([USE_OSSFUZZERS], [test "false" = "true"])
fi
-AM_CONDITIONAL([USE_OSSFUZZ_FLAG], [test "x$LIB_FUZZING_ENGINE" = "x-fsanitize=fuzzer"])
-AM_CONDITIONAL([USE_OSSFUZZ_STATIC], [test -f "$LIB_FUZZING_ENGINE"])
AC_SUBST([LIB_FUZZING_ENGINE])
dnl check for ogg library