summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartijn van Beurden <mvanb1@gmail.com>2022-08-13 15:20:42 +0200
committerGitHub <noreply@github.com>2022-08-13 15:20:42 +0200
commit010c60e1f9ad20b42863cfe7bed49593b4cccb1f (patch)
tree8cde771890f1a169bd6eee560ec402986837dc0b /configure.ac
parent9bc2cc4c3b4b6befa3cf09f364e4f6a0bdfc46e1 (diff)
downloadflac-010c60e1f9ad20b42863cfe7bed49593b4cccb1f.tar.gz
Add configure option to not build programs
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index df468e25..3a20cdb3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -452,6 +452,11 @@ AC_DEFINE_UNQUOTED([FLAC__HAS_OGG],$FLAC__HAS_OGG,[define if you have the ogg li
AC_SUBST(FLAC__HAS_OGG)
AC_SUBST(OGG_PACKAGE)
+dnl Build programs?
+AC_ARG_ENABLE([programs],
+ AS_HELP_STRING([--disable-programs], [Don't build and install flac and metaflac]))
+AM_CONDITIONAL(FLaC__WITH_PROGRAMS, [test "x$enable_programs" != "xno"])
+
dnl Build examples?
AC_ARG_ENABLE([examples],
AS_HELP_STRING([--disable-examples], [Don't build and install examples]))