summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNotTsunami <4589807+NotTsunami@users.noreply.github.com>2022-04-18 02:45:14 -0400
committerMartijn van Beurden <mvanb1@gmail.com>2022-04-21 19:35:58 +0200
commitb171e767e282909d3f4ef4b7d7fcb9b7d7987ff5 (patch)
tree64ef2f1f4a16cdebfb942add8f2c7f932f088df3 /CMakeLists.txt
parentf579b163fe7ccdb0f713001d4253c5d68a3b8280 (diff)
downloadflac-b171e767e282909d3f4ef4b7d7fcb9b7d7987ff5.tar.gz
Add missing langinfo check for CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0a19fac1..6163a254 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -105,6 +105,14 @@ check_function_exists(fseeko HAVE_FSEEKO)
check_c_source_compiles("int main() { return __builtin_bswap16 (0) ; }" HAVE_BSWAP16)
check_c_source_compiles("int main() { return __builtin_bswap32 (0) ; }" HAVE_BSWAP32)
+check_c_source_compiles("
+ #include <langinfo.h>
+ int main()
+ {
+ char* cs = nl_langinfo(CODESET);
+ return !cs;
+ }"
+ HAVE_LANGINFO_CODESET)
test_big_endian(CPU_IS_BIG_ENDIAN)