summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRonenGvili <92885945+RonenGvili@users.noreply.github.com>2022-04-29 15:46:07 +0300
committerGitHub <noreply@github.com>2022-04-29 14:46:07 +0200
commit95e2c52980977e78976e2090d19e4cbae9d0a2e9 (patch)
tree55e2d788b735cabaeefa28932b9a295e6bb7ba60 /CMakeLists.txt
parent5df56dbcf50bdbc1924bc097567549995d3b3a70 (diff)
downloadflac-95e2c52980977e78976e2090d19e4cbae9d0a2e9.tar.gz
Adding ARM64 support and optimized Neon implementation (#270)
Add NEON intrinsics routines for lpc_compute_residual_from_qlp_coefficients and lpc_compute_residual_from_qlp_coefficients_wide
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7e6ae233..4b6d0682 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -104,6 +104,8 @@ enable_testing()
check_include_file("byteswap.h" HAVE_BYTESWAP_H)
check_include_file("inttypes.h" HAVE_INTTYPES_H)
check_include_file("stdint.h" HAVE_STDINT_H)
+check_include_file("arm_neon.h" FLAC__HAS_NEONINTRIN)
+
if(MSVC)
check_include_file("intrin.h" FLAC__HAS_X86INTRIN)
else()