summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartijn van Beurden <mvanb1@gmail.com>2022-01-04 07:52:10 +0100
committerMartijn van Beurden <mvanb1@gmail.com>2022-04-13 17:37:50 +0200
commit6e3089b9bc6e154b9330120dbc0e4d5968986984 (patch)
tree6412c555177022e23f5d23042b41f4246528b590 /CMakeLists.txt
parent805b7dba834ecf26904a7b21adeee5bab7ad617d (diff)
downloadflac-6e3089b9bc6e154b9330120dbc0e4d5968986984.tar.gz
[CMake] Add BUILD_SHARED_LIBS as options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e763008c..5c97eb1c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,7 @@ option(INSTALL_MANPAGES "Install MAN pages" ON)
option(INSTALL_PKGCONFIG_MODULES "Install PkgConfig modules" ON)
option(INSTALL_CMAKE_CONFIG_MODULE "Install CMake package-config module" ON)
option(WITH_OGG "ogg support (default: test for libogg)" ON)
+option(BUILD_SHARED_LIBS "Build shared instead of static libraries" OFF)
set(VERSION ${PROJECT_VERSION})