summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartijn van Beurden <mvanb1@gmail.com>2022-07-20 14:52:18 +0200
committerMartijn van Beurden <mvanb1@gmail.com>2022-08-01 21:02:03 +0200
commit428e681784b57de38bdb94924e642e071799c703 (patch)
tree06c4c49825daa11ae45e15ceb7c61bd769bd2277 /CMakeLists.txt
parent4e823662ec5121e84d7d5ca3aa62cf87064b229f (diff)
downloadflac-428e681784b57de38bdb94924e642e071799c703.tar.gz
[CMake] Don't search for libiconv and libintl on Windows
The functions these libs provide don't seem to be used on Windows anyway. This fixes https://github.com/xiph/flac/issues/249
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 761dd49b..2aa7daea 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -77,8 +77,10 @@ if(HAVE_GIT)
)
endif()
-find_package(Iconv)
-set(HAVE_ICONV ${Iconv_FOUND})
+if(NOT WIN32)
+ find_package(Iconv)
+ set(HAVE_ICONV ${Iconv_FOUND})
+endif()
if(CMAKE_C_COMPILER_ID MATCHES "GNU|Clang")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wstrict-prototypes -Wmissing-prototypes -Waggregate-return -Wcast-align -Wnested-externs -Wshadow -Wundef -Wmissing-declarations -Winline")