summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorllane <llane>1999-11-19 13:42:45 +0000
committerllane <llane@7cbeb6ba-43b4-40fd-8cce-4c39aea84d33>1999-11-19 13:42:45 +0000
commitc6e3fdbac9fcdcf7b2e18c867e6b3323103aa8b7 (patch)
tree085ef666be19ed86b4be8160775532356e876add /debian
parentc58c7d411b8a1a7198b93116bd992a4d6243a192 (diff)
downloadeterm-c6e3fdbac9fcdcf7b2e18c867e6b3323103aa8b7.tar.gz
synch stuff
SVN revision: 1335
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/control1
-rw-r--r--debian/menu2
-rw-r--r--debian/rules30
4 files changed, 24 insertions, 15 deletions
diff --git a/debian/changelog b/debian/changelog
index c966714..bbc15f6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+eterm (0.9.0-0-cvs0a) unstable; urgency=low
+
+ * Yet Another CVS Release
+
+ -- Laurence John Lane <ljlane@debian.org> Thu, 18 Nov 1999 13:41:21 -0500
+
eterm (0.9.0-0-cvs00) unstable; urgency=low
* changed cvs version numbering
diff --git a/debian/control b/debian/control
index 0336988..b1cf126 100644
--- a/debian/control
+++ b/debian/control
@@ -13,4 +13,3 @@ Description: Enlightened Terminal Emulator (ala xterm) with Imlib support
Imlib graphics engine is used to render images. This version supports
background images, pixmap shading/tinting, and pseudo-transparency.
Eterm also now uses libpthreads.
-
diff --git a/debian/menu b/debian/menu
index 85ab8df..075aad6 100644
--- a/debian/menu
+++ b/debian/menu
@@ -1,2 +1,2 @@
?package(eterm):needs=X11 section=XShells\
- title="Eterm" command="/usr/bin/X11/Eterm"
+ title="Eterm" command="/usr/bin/Eterm"
diff --git a/debian/rules b/debian/rules
index f0bc771..6313c59 100644
--- a/debian/rules
+++ b/debian/rules
@@ -2,45 +2,49 @@
export DH_COMPAT=2
-vpath build debian
-vpath install debian
+vpath build debian/pmt/
+vpath install debian/pmt/
cfg = --prefix=/usr --mandir=/usr/share/man
+pwd := $(shell pwd)
build:
dh_testdir
test -x autogen.sh && ./autogen.sh $(cfg) || ./configure $(cfg)
+ install -d debian/pmt/
+
# because glibc 2.1's utmpx.h is incompatible on sparc
- sed 's/#define HAVE_UTMPX_H 1/\/* #undef HAVE_UTMPX_H *\//' config.h > config.h.tmp
- mv config.h.tmp config.h
+ sed 's/#define HAVE_UTMPX_H 1/\/* #undef HAVE_UTMPX_H *\//' config.h > debian/pmt/config.h
+ cp debian/pmt/config.h config.h
# fix rpath issues
- cp libtool libtool-2
+ cp libtool debian/pmt/libtool
sed \
-e 's/^hardcode_libdir_flag_spec.*$$/hardcode_libdir_flag_spec="-D__LIBTOOL_IS_A_FOOL__ "/' \
- -e '/^archive_cmds="/s/"$$/ \\$$deplibs"/' libtool-2 > libtool
+ -e '/^archive_cmds="/s/"$$/ \\$$deplibs"/' debian/pmt/libtool > libtool
$(MAKE)
- touch debian/$@
+ touch debian/pmt/$@
clean:
dh_testdir
dh_testroot
rm -f build-stamp
- test -f Makefile && $(MAKE) -k distclean
- dh_clean debian/{build,install,libtool-2}
+ -$(MAKE) -k distclean clean
+ rm -rvf debian/pmt/
+ dh_clean
install: build
dh_testdir
dh_testroot
dh_clean
dh_installdirs
- $(MAKE) install DESTDIR=$(shell pwd)/debian/eterm
- touch debian/$@
+ $(MAKE) install DESTDIR=$(pwd)/debian/eterm
+ touch debian/pmt/$@
binary-arch: build install
dh_testdir
dh_testroot
- dh_installdocs README ReleaseNotes doc/{FAQ.html,Eterm.tcap,Eterm.ti,Eterm_reference.html}
+ dh_installdocs README ReleaseNotes doc/{Eterm.tcap,Eterm.ti,Eterm_reference.html}
dh_installmenu
dh_undocumented Esetroot.1 Etbg.1 Etcolors.1 Ettable.1 Etwinop.1
dh_installchangelogs
@@ -50,7 +54,7 @@ binary-arch: build install
dh_suidregister usr/bin/Eterm
dh_installdeb
dh_makeshlibs
- dh_shlibdeps
+ dh_shlibdeps -l$(pwd)/debian/Eterm/usr/lib
dh_gencontrol
dh_md5sums
dh_builddeb