summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorLaurence J. Lane <ljlane@users.sourceforge.net>2001-03-04 02:34:37 +0000
committerLaurence J. Lane <ljlane@users.sourceforge.net>2001-03-04 02:34:37 +0000
commit1a4e2e927cd125a8c59dffb90e87734cf07f38e7 (patch)
treea60a399d5d6f9777d9b5202131237e6cd84615bb /debian
parent8dd52b84f1617aed14d46f2cbbe1433a8cd01e43 (diff)
downloadeterm-1a4e2e927cd125a8c59dffb90e87734cf07f38e7.tar.gz
peace in the valley
SVN revision: 4306
Diffstat (limited to 'debian')
-rw-r--r--debian/rules76
1 files changed, 76 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100644
index 0000000..8b457f8
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,76 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+
+export DH_COMPAT=1
+pwd:=$(shell pwd)
+
+cfg = --mandir=/usr/share/man --enable-fsstd \
+ --enable-xim --with-backspace=del --with-delete=execute \
+ --with-home=linux --with-end=linux
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+
+ ./autogen.sh ${cfg}
+
+ install -d debian/pmt/
+
+ # because glibc 2.1's utmpx.h is incompatible on sparc
+ sed 's/#define HAVE_UTMPX_H 1/\/* #undef HAVE_UTMPX_H *\//' config.h > debian/pmt/config.h
+ cp debian/pmt/config.h config.h
+
+ # fix rpath issues
+ cp libtool debian/pmt/libtool
+ sed \
+ -e 's/^hardcode_libdir_flag_spec.*$$/hardcode_libdir_flag_spec="-D__LIBTOOL_IS_A_FOOL__ "/' \
+ -e '/^archive_cmds="/s/"$$/ \\$$deplibs"/' debian/pmt/libtool > libtool
+ $(MAKE)
+ touch debian/pmt/$@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp config.cache
+
+ # Add here commands to clean up after the build process.
+ -$(MAKE) clean
+ -rm -rf debian/pmt/
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/tmp.
+ $(MAKE) install DESTDIR=$(pwd)/debian/tmp
+ install -d $(pwd)/debian/tmp/usr/share/doc/eterm
+ install $(pwd)/ChangeLog $(pwd)/debian/tmp/usr/share/doc/eterm
+
+
+binary-indep: build install
+
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs
+ dh_installmenu
+ dh_installchangelogs
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install