summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Jennings <mej@kainx.org>1999-12-06 17:20:16 +0000
committerMichael Jennings <mej@kainx.org>1999-12-06 17:20:16 +0000
commit8856f0a2259cc521baeb542f08a4d7e42a21e84f (patch)
treef857dc34cee89f826a5a1c660ac6a5abca71eb64 /configure.in
parentb1994ddf16e77aec9c8a57a4e755c56771461406 (diff)
downloadeterm-8856f0a2259cc521baeb542f08a4d7e42a21e84f.tar.gz
Mon Dec 6 14:05:36 PST 1999 Michael Jennings <mej@eterm.org>
Added support for the Pablo Performance Analysis Toolkit (http://www-pablo.cs.uiuc.edu/Software/Pablo/pablo.htm). SVN revision: 1510
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index df1c1e1..966ded6 100644
--- a/configure.in
+++ b/configure.in
@@ -208,6 +208,33 @@ fi
dnl#
dnl# FEATURES
dnl#
+AC_MSG_CHECKING(if Pablo support is wanted)
+AC_ARG_WITH(pablo,
+[ --with-pablo[=DIR] compile with Pablo I/O Tracing support (using Pablo prefix DIR)],
+ if test "$withval" != "no"; then
+ AC_MSG_RESULT(yes)
+ if test "$withval" != "yes"; then
+ CPPFLAGS="$CPPFLAGS -I${withval}/include"
+ LDFLAGS="$LDFLAGS -L${withval}/lib"
+ fi
+ AC_CHECK_HEADER(IOTrace.h,
+ AC_CHECK_LIB(PabloTraceExt, initIOTrace,
+ AC_DEFINE(IOTRACE)
+ LIBS="$LIBS -lPabloTraceExt -lPabloTrace"
+ echo "Pablo support enabled. Headers in ${withval}/include. Libraries in ${withval}/lib."
+ ,
+ echo "*** ERROR: Pablo support was requested but the Pablo libraries could not be"
+ echo "*** found. Please check config.log for further information."
+ echo "*** Pablo support will NOT be included."
+ , -lPabloTrace)
+ ,
+ echo "*** ERROR: Pablo support was requested but the Pablo header files could not be"
+ echo "*** found. Please check the value you passed to --with-pablo."
+ echo "*** Pablo support will NOT be included.")
+ else
+ AC_MSG_RESULT(no)
+ fi, AC_MSG_RESULT(no)
+)
AC_MSG_CHECKING(for pixmap support)
AC_ARG_WITH(imlib,
[ --with-imlib[=DIR] compile with Imlib support (Imlib residing in DIR/lib) (default)],