summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKim Woelders <kim@woelders.dk>2010-08-10 18:08:44 +0000
committerKim Woelders <kim@woelders.dk>2010-08-10 18:08:44 +0000
commitc81f5795de828ab88232f5a7481437f17b9e6831 (patch)
tree2b7b406f96f23bac93d2fcf1c4843ba86cfdd5d0 /configure.ac
parent8f2dd859a637a7d222ae15d8edc286497a14c686 (diff)
downloadeterm-c81f5795de828ab88232f5a7481437f17b9e6831.tar.gz
Eliminate use of Xmu.
This causes the following change: In script.c and term.c XA_CLIPBOARD(Xdisplay) used to expand to XA_PRIMARY, i.e. the identifier of the "PRIMARY" atom, now it will be the identifier of the "CLIPBOARD" atom. SVN revision: 50969
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 1 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 90f796c..707bc1b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -205,8 +205,7 @@ sys/ioctl.h sys/select.h sys/time.h \
sys/sockio.h sys/byteorder.h malloc.h \
utmpx.h unistd.h bsd/signal.h regex.h \
regexp.h stdarg.h X11/X.h X11/Xlib.h \
-X11/Xmu/Atoms.h X11/Sunkeysym.h \
-X11/Xlocale.h \
+X11/Sunkeysym.h X11/Xlocale.h \
)
AC_HEADER_TIME
@@ -872,11 +871,6 @@ AC_ARG_ENABLE(xim,
XIM="TRUE"
])
-# For multibyte selection handling
-#if test "$MULTICHAR_ENCODING" != "none"; then
- AC_CHECK_LIB(Xmu, XmuInternAtom)
-#fi
-
# check X11R6 for XIM
if test "$XIM" = "TRUE"; then
AC_CHECK_LIB(X11, XRegisterIMInstantiateCallback, AC_DEFINE(USE_X11R6_XIM, , [Define if we have X11R6 XIM.]))