summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authortzz <tzz>2002-02-20 14:44:46 +0000
committertzz <tzz@7cbeb6ba-43b4-40fd-8cce-4c39aea84d33>2002-02-20 14:44:46 +0000
commitbff50aaeeedeb36ad468b77a869f031b159bdab6 (patch)
tree5df1eacb2ebfde2b3efbfc413431bfef3250b9c1 /configure.ac
parent9da97da220cd09387e1689d5c5e9c374fcb092f4 (diff)
downloadeterm-bff50aaeeedeb36ad468b77a869f031b159bdab6.tar.gz
applied automatic encodings patch, see ChangeLog. Also a minor CONFIG_BUFF
missing define fix. SVN revision: 5962
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 60292c3..7529f98 100644
--- a/configure.ac
+++ b/configure.ac
@@ -181,7 +181,7 @@ AC_TYPE_SIGNAL
AC_CHECK_FUNCS(atexit _exit unsetenv setutent \
seteuid memmove putenv strsep setresuid setresgid \
memmem usleep snprintf strcasestr strcasechr \
-strcasepbrk strrev)
+strcasepbrk strrev nl_langinfo)
dps_snprintf_oflow()
AC_CHECK_LIB(m, pow)
@@ -594,6 +594,18 @@ AC_ARG_WITH(mousewheel,
AC_DEFINE(MOUSEWHEEL)
])
+AC_MSG_CHECKING(for automatic encoding)
+AC_ARG_ENABLE(auto-encoding,
+[ --enable-auto-encoding compile with runtime automatic encoding setting],
+ if test "$enableval" = "no"; then
+ AC_MSG_RESULT(no)
+ else
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(AUTO_ENCODING)
+ fi, AC_MSG_RESULT(yes)
+ AC_DEFINE(AUTO_ENCODING)
+)
+
MULTICHAR_ENCODING=""
AC_MSG_CHECKING(for multi-charset support)
AC_ARG_ENABLE(multi-charset,