summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@osg.samsung.com>2016-03-02 09:25:43 +0100
committerStefan Schmidt <stefan@osg.samsung.com>2016-03-02 09:25:43 +0100
commitf4b8e7517e9301cbbeea3e5b191fbdd277e153be (patch)
treefc0733ad1b5a210718b9199732c38a967c89bea8 /Makefile.am
parentc20d34a8007c527d1a9531976aaae2e93eea1590 (diff)
downloadelementary-f4b8e7517e9301cbbeea3e5b191fbdd277e153be.tar.gz
build: enhance generated html output from coverage report
We do not handle branch coverage so remove that part of the output. On the other hand at a legend to allow people to understand the color meanings.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 334062299..387a07145 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -140,7 +140,7 @@ lcov-report:
lcov --remove $(top_builddir)/coverage/coverage.cleaned2.info '*/elm_suite.c' --output-file $(top_builddir)/coverage/coverage.cleaned3.info
lcov --remove $(top_builddir)/coverage/coverage.cleaned3.info '*NONE*' --output-file $(top_builddir)/coverage/coverage.cleaned4.info
lcov --remove $(top_builddir)/coverage/coverage.cleaned4.info '*/datetime_input_ctxpopup.c' '*/elm_horizontal_box.c' '*/elm_vertical_frame.c' '*/elm_vertical_box.c' '*/elm_horizontal_frame.c' '*/prefs_iface.c' '*/elm_swallow.c' --output-file $(top_builddir)/coverage/coverage.cleaned5.info
- genhtml --branch-coverage -t "$(PACKAGE_STRING)" -o $(top_builddir)/coverage/html $(top_builddir)/coverage/coverage.cleaned5.info
+ genhtml --legend -t "$(PACKAGE_STRING)" -o $(top_builddir)/coverage/html $(top_builddir)/coverage/coverage.cleaned5.info
@echo "Coverage Report at $(top_builddir)/coverage/html"
endif