summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTom Hacohen <tom@stosb.com>2011-02-03 15:52:49 +0000
committerTom Hacohen <tom@stosb.com>2011-02-03 15:52:49 +0000
commit2df265f510490da197fde52a382f81516ad437a6 (patch)
tree6c8a25a2558b573b5bcec671db7035dbb9bb583d /Makefile.am
parenta04a0d7f4eaf6912088947a853019e5ded71f7d5 (diff)
downloadelementary-2df265f510490da197fde52a382f81516ad437a6.tar.gz
Elementary: Added the infrastructure for ui-mirroring support.
* Added elm_mirrored_get/set to set the system mirrored mode * Added elm_widget_mirrored/get/set to set each widget's mirrored mode. * Added code to set the system mirrored mode from translations to elementary and added translations for all the rtl languages. (a trick to load according to locale). * Future commits will include specific widgets mirrored mode handling. Work by Aharon Hillel and Tom Hacohen. SVN revision: 56673
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am38
1 files changed, 36 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f41c83e91..01a359838 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,15 @@
SUBDIRS = src data config doc
+if HAVE_PO
+
+SUBDIRS += po
+
+endif
+
ACLOCAL_AMFLAGS = -I m4
MAINTAINERCLEANFILES = \
+ABOUT-NLS \
Makefile.in \
aclocal.m4 \
config.guess \
@@ -20,7 +27,33 @@ m4/libtool.m4 \
m4/lt~obsolete.m4 \
m4/ltoptions.m4 \
m4/ltsugar.m4 \
-m4/ltversion.m4
+m4/ltversion.m4 \
+m4/gettext.m4 \
+m4/iconv.m4 \
+m4/lcmessage.m4 \
+m4/lib-ld.m4 \
+m4/lib-link.m4 \
+m4/lib-prefix.m4 \
+m4/nls.m4 \
+m4/po.m4 \
+m4/progtest.m4
+
+if HAVE_PO
+
+MAINTAINERCLEANFILES += \
+po/boldquot.sed \
+po/en@boldquot.header \
+po/en@quot.header \
+po/insert-header.sin \
+po/Makefile.in.in \
+po/Makevars.template \
+po/quot.sed \
+po/remove-potcdate.sin \
+po/Rules-quot
+
+endif
+
+
EXTRA_DIST = \
@@ -33,7 +66,8 @@ elementary.spec \
elementary.spec.in \
m4/ac_attribute.m4 \
m4/efl_binary.m4 \
-m4/efl_doxygen.m4
+m4/efl_doxygen.m4 \
+config.rpath
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = elementary.pc