summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@osg.samsung.com>2016-01-13 16:25:47 +0100
committerStefan Schmidt <stefan@osg.samsung.com>2016-01-13 16:27:23 +0100
commit2d17f7894e931c50728bc4651b07a01c88644f5f (patch)
tree1228e4a7571932c2072d4a804200cdd9a55287ef /configure.ac
parent49ef37457adce6f7ac2fee6a1d4bf8b81806b47a (diff)
downloadefl-2d17f7894e931c50728bc4651b07a01c88644f5f.tar.gz
build: check for dlopen() when we build the ecore_evas drm module
We use it to check for libglapi.so.0 Original patch by aerodynamik ref T2953
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 004032393f..0ee5a4c576 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4342,6 +4342,9 @@ EFL_EVAL_PKGS([ECORE_EVAS])
### Checks for linker characteristics
### Checks for library functions
+if test "x${want_gl_drm}" = "xyes" ; then
+ EFL_CHECK_FUNCS([ECORE_EVAS], [dlopen])
+fi
EFL_LIB_END([Ecore_Evas])
#### End of Ecore_Evas