summaryrefslogtreecommitdiff
path: root/unittests/enchant_providers/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'unittests/enchant_providers/Makefile.am')
-rw-r--r--unittests/enchant_providers/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/unittests/enchant_providers/Makefile.am b/unittests/enchant_providers/Makefile.am
index 3cbf489..acf2076 100644
--- a/unittests/enchant_providers/Makefile.am
+++ b/unittests/enchant_providers/Makefile.am
@@ -2,8 +2,8 @@ AM_CPPFLAGS = -I$(top_srcdir)/src $(ENCHANT_CFLAGS) $(UNITTESTPP_CFLAGS)
# FIXME: .so extension will not work on Windows
AM_TESTS_ENVIRONMENT = \
- cp $(builddir)/../mock_provider/*.so $(builddir)/../mock_provider/.libs/*.so . || :; \
- cp $(top_builddir)/src/*/*.so $(top_builddir)/src/*/.libs/*.so . || :;
+ cp $(builddir)/../mock_provider/*.so $(builddir)/../mock_provider/.libs/*.so $(builddir)/../mock_provider/*.dll $(builddir)/../mock_provider/.libs/*.dll . || :;
+ cp $(top_builddir)/src/*/*.so $(top_builddir)/src/*/.libs/*.so cp $(top_builddir)/src/*/*.dll $(top_builddir)/src/*/.libs/*.dll . || :;
DEPS = $(top_builddir)/src/libenchant.la
ldadd = $(top_builddir)/src/libenchant.la $(ENCHANT_LIBS)
@@ -28,4 +28,4 @@ main_LDFLAGS =
main_DEPENDENCIES = $(DEPS)
main_LDADD = $(ldadd) $(UNITTESTPP_LIBS)
-DISTCLEANFILES = libenchant_*.so
+DISTCLEANFILES = libenchant_*.so *enchant*.dll