summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b40b174..96b45a2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -24,11 +24,18 @@ noinst_HEADERS = debug.h
pkgdata_DATA = enchant.ordering
dist_man_MANS = enchant-@ENCHANT_MAJOR_VERSION@.1 enchant-lsmod-@ENCHANT_MAJOR_VERSION@.1 enchant.5
+nodist_doc_DATA = enchant-@ENCHANT_MAJOR_VERSION@.html enchant-lsmod-@ENCHANT_MAJOR_VERSION@.html enchant.html
edit = sed \
-e 's|DATADIR|$(datadir)|g'
-DISTCLEANFILES = $(dist_man_MANS)
+DISTCLEANFILES = $(dist_man_MANS) $(nodist_doc_DATA)
+
+.1.html:
+ groff -mandoc -Thtml $< > $@
+
+enchant.html: enchant.5
+ groff -mandoc -Thtml $< > $@
enchant-@ENCHANT_MAJOR_VERSION@.1: $(builddir)/enchant.1 Makefile.am $(top_builddir)/config.status
rm -f $@ $@.tmp