summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2008-10-24 04:26:53 +0000
committerGlenn Morris <rgm@gnu.org>2008-10-24 04:26:53 +0000
commitef913c89bc8ba93058d2493c1068bd0fe595bf25 (patch)
tree17d6e8bd3d50fbf0b6f78ead97d70da3ba520b37 /configure.in
parentd8c967ad2e99da8b2197456bd28a5b9092a39e2b (diff)
downloademacs-ef913c89bc8ba93058d2493c1068bd0fe595bf25.tar.gz
Yavor Doganov <yavor at gnu.org> (tiny change)
Use `.' instead of `source' to source GNUstep.conf. Exit with an error if `--with-ns' was specified but <AppKit/AppKit.h> is not found. (Bug#1230)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 8e3c8e998ca..e01d9be3132 100644
--- a/configure.in
+++ b/configure.in
@@ -1239,15 +1239,17 @@ if test "${with_ns}" != no; then
ns_appbindir=`pwd`/nextstep/Emacs.app
ns_appresdir=`pwd`/nextstep/Emacs.app/Resources
ns_appsrc=${srcdir}/nextstep/GNUstep/Emacs.base
- GNUSTEP_MAKEFILES="$(source /etc/GNUstep/GNUstep.conf; echo $GNUSTEP_MAKEFILES)"
- GNUSTEP_SYSTEM_HEADERS="$(source /etc/GNUstep/GNUstep.conf; echo $GNUSTEP_SYSTEM_HEADERS)"
- GNUSTEP_SYSTEM_LIBRARIES="$(source /etc/GNUstep/GNUstep.conf; echo $GNUSTEP_SYSTEM_LIBRARIES)"
+ GNUSTEP_MAKEFILES="$(. /etc/GNUstep/GNUstep.conf; echo $GNUSTEP_MAKEFILES)"
+ GNUSTEP_SYSTEM_HEADERS="$(. /etc/GNUstep/GNUstep.conf; echo $GNUSTEP_SYSTEM_HEADERS)"
+ GNUSTEP_SYSTEM_LIBRARIES="$(. /etc/GNUstep/GNUstep.conf; echo $GNUSTEP_SYSTEM_LIBRARIES)"
CPPFLAGS="$CPPFLAGS -I${GNUSTEP_SYSTEM_HEADERS}"
CFLAGS="$CFLAGS -I${GNUSTEP_SYSTEM_HEADERS}"
REAL_CFLAGS="$REAL_CFLAGS -I${GNUSTEP_SYSTEM_HEADERS}"
LDFLAGS="$LDFLAGS -L${GNUSTEP_SYSTEM_LIBRARIES}"
fi
- AC_CHECK_HEADER(AppKit/AppKit.h, HAVE_NS=yes)
+ AC_CHECK_HEADER([AppKit/AppKit.h], [HAVE_NS=yes],
+ [AC_MSG_ERROR([`--with-ns' was specified, but the include
+ files are missing or cannot be compiled.])])
NS_HAVE_NSINTEGER=yes
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([#include <Foundation/NSObjCRuntime.h>],
[NSInteger i;])],