summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKarl Heuer <kwzh@gnu.org>1998-04-07 04:00:53 +0000
committerKarl Heuer <kwzh@gnu.org>1998-04-07 04:00:53 +0000
commitaef8a36fb09453f4be66be9d04a16cd6e8f1fe44 (patch)
tree58afc53f1bd301934d740169e03685a7d80bdec8 /configure.in
parente0834ad2c7fd755c09a90ab59ff097d7b00941bf (diff)
downloademacs-aef8a36fb09453f4be66be9d04a16cd6e8f1fe44.tar.gz
Add --with-gssapi to specify GSS-API
authentication support for movemail.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 7fcc825a3cd..0196170f8fa 100644
--- a/configure.in
+++ b/configure.in
@@ -54,6 +54,9 @@ AC_DEFINE(KERBEROS5)])
AC_ARG_WITH(hesiod,
[ --with-hesiod support Hesiod to get the POP server host],
[AC_DEFINE(HESIOD)])
+AC_ARG_WITH(gssapi,
+[ --with-gssapi support GSSAPI-authenticated POP],
+[AC_DEFINE(GSSAPI)])
dnl This should be the last --with option, because --with-x is
dnl added later on when we find the path of X, and it's best to
dnl keep them together visually.
@@ -1623,7 +1626,11 @@ if test "${with_kerberos+set}" = set; then
AC_CHECK_LIB(com_err, com_err)
AC_CHECK_LIB(crypto, mit_des_cbc_encrypt)
AC_CHECK_LIB(krb5, krb5_init_context)
- if test "${with_kerberos5+set}" != set; then
+ if test "${with_kerberos5+set}" = set; then
+ if test "${with_gssapi+set}" = set; then
+ AC_CHECK_LIB(gssapi_krb5,gss_init_sec_context)
+ fi
+ else
AC_CHECK_LIB(des, des_cbc_encrypt,,
AC_CHECK_LIB(des425, des_cbc_encrypt))
AC_CHECK_LIB(krb, krb_get_cred,,
@@ -1643,6 +1650,11 @@ if test "${with_kerberos+set}" = set; then
AC_CHECK_HEADERS(com_err.h)
fi
+if test "${with_gssapi+set}" = set; then
+ AC_CHECK_LIB(gssapi, gss_init_sec_context)
+ AC_CHECK_HEADERS(gssapi.h)
+fi
+
# Solaris requires -lintl if you want strerror (which calls dgettext)
# to return localized messages.
AC_CHECK_LIB(intl, dgettext)