summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDave Love <fx@gnu.org>2003-06-29 12:01:08 +0000
committerDave Love <fx@gnu.org>2003-06-29 12:01:08 +0000
commita6c2ef66b23dfc884c173e5a8c79477b30def1fd (patch)
tree3d7115d6549ce07b185b262f2dbd6f5baf36d278 /configure.in
parent78bcc1482ac6d17adf98963391c5ea3c166715e8 (diff)
downloademacs-a6c2ef66b23dfc884c173e5a8c79477b30def1fd.tar.gz
Fix XRegisterIMInstantiateCallback check for gcc.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0433c0ae210..800e80dd079 100644
--- a/configure.in
+++ b/configure.in
@@ -2049,6 +2049,10 @@ dnl with `--with-xim=no'.
if test "${with_xim}" != "no"; then
AC_DEFINE(USE_XIM, 1,
[Define to 1 if we should use XIM, if it is available.])
+ late_CFLAGS=$CFLAGS
+ if test "$GCC" = yes; then
+ CFLAGS="$CFLAGS --pedantic-errors"
+ fi
AC_TRY_COMPILE([
#include <X11/Xlib.h>
#include <X11/Xresource.h>],
@@ -2058,6 +2062,12 @@ char *res_name;
char *res_class;
XIMProc callback;
XPointer *client_data;
+#ifndef __GNUC__
+/* If we're not using GCC, it's probably not XFree86, and this is
+ probably right, but we can't use something like --pedantic-errors. */
+extern Bool XRegisterIMInstantiateCallback(Display*, XrmDatabase, char*,
+ char*, XIMProc, XPointer*);
+#endif
(void)XRegisterIMInstantiateCallback(display, db, res_name, res_class, callback,
client_data);],
[emacs_cv_arg6_star=yes])
@@ -2069,6 +2079,7 @@ either XPointer or XPointer*.])dnl
else
AC_DEFINE(XRegisterIMInstantiateCallback_arg6, [XPointer])
fi
+ CFLAGS=$late_CFLAGS
fi
### Use -lXpm if available, unless `--with-xpm=no'.