summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2012-06-12 14:44:31 -0400
committerGlenn Morris <rgm@gnu.org>2012-06-12 14:44:31 -0400
commit8a07a8c6fe3c0ed64d0dbbc1c9789ce970341fdb (patch)
tree6dc27b5f46803f90cd15cca64f466070fbe8dce0 /configure.in
parentad4d226cb8e04acf5063f343772dcb3ba950849e (diff)
downloademacs-8a07a8c6fe3c0ed64d0dbbc1c9789ce970341fdb.tar.gz
Remove src/s/hpux11.h
* configure.in (BROKEN_SA_RESTART, USG_SUBTTY_WORKS): New AC_DEFINEs. (opsysfile): Set specially for hpux11. * src/s/hpux11.h: Remove file.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0b4acaa5240..dea8c96591b 100644
--- a/configure.in
+++ b/configure.in
@@ -3125,8 +3125,19 @@ case $opsys in
;;
esac
+if test "$opsys" = hpux11; then
+ dnl SA_RESTART resets the timeout of `select', so don't use it.
+ AC_DEFINE(BROKEN_SA_RESTART, 1, [Define if SA_RESTART should not be used.])
+ dnl It works to open the pty's tty in the parent (Emacs), then close
+ dnl and reopen it in the child.
+ AC_DEFINE(USG_SUBTTY_WORKS, 1, [Define for USG systems where it
+ works to open a pty's tty in the parent process, then close and
+ reopen it in the child.])
+fi
+
case $opsys in
gnu-kfreebsd) opsysfile="s/gnu-linux.h" ;;
+ hpux11) opsysfile="s/hpux10-20.h" ;;
openbsd) opsysfile="s/netbsd.h" ;;
esac