summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDave Love <fx@gnu.org>2002-11-27 22:53:51 +0000
committerDave Love <fx@gnu.org>2002-11-27 22:53:51 +0000
commit71cc40d5d4c554d939ffb8c2029ee508cb809822 (patch)
treea1c95899133ac970e6dcdc834b416538898277e6 /configure.in
parent454b4dd09f5cc37ed756e73509b19e1ca6058188 (diff)
downloademacs-71cc40d5d4c554d939ffb8c2029ee508cb809822.tar.gz
Use AC_CHECK_DECLS, not AC_DECL_SYS_SIGLIST.
Check for __sys_siglist too. Check for memset. Use AC_FUNC_GETPGRP. Add mipsel-*-linux-gnu* target.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 18 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 8e3f1ecf8c8..5087dd94e7e 100644
--- a/configure.in
+++ b/configure.in
@@ -1081,7 +1081,7 @@ case "${canonical}" in
;;
## Mips Linux-based GNU system
- mips-*-linux-gnu* )
+ mips-*-linux-gnu* | mipsel-*-linux-gnu* )
machine=mips opsys=gnu-linux
;;
@@ -1401,7 +1401,15 @@ dnl it doesn't define `bool'.
AC_CHECK_HEADERS(term.h, , , -)
AC_HEADER_STDC
AC_HEADER_TIME
-AC_DECL_SYS_SIGLIST
+AC_CHECK_DECLS([sys_siglist])
+if test $ac_cv_have_decl_sys_siglist != yes; then
+ # For Tru64, at least:
+ AC_CHECK_DECLS([__sys_siglist])
+ if test $ac_cv_have_decl___sys_siglist = yes; then
+ AC_DEFINE(sys_siglist, __sys_siglist,
+ [Define to any substitute for sys_siglist.])
+ fi
+fi
AC_HEADER_SYS_WAIT
dnl Some systems have utime.h but don't declare the struct anyplace.
@@ -1494,6 +1502,10 @@ AH_TEMPLATE(POINTER_TYPE,
[Define as `void' if your compiler accepts `void *'; otherwise
define as `char'.])dnl
+dnl This could be used for targets which can have both byte sexes.
+dnl We could presumably replace the hardwired WORDS_BIG_ENDIAN generally.
+dnl AC_C_BIGENDIAN
+
dnl check for Make feature
AC_PROG_MAKE_SET
@@ -1951,7 +1963,7 @@ fi
HAVE_JPEG=no
if test "${HAVE_X11}" = "yes"; then
if test "${with_jpeg}" != "no"; then
- dnl Checking for jpeglib.h can lose becsue of a redefinition of
+ dnl Checking for jpeglib.h can lose because of a redefinition of
dnl HAVE_STDLIB_H.
AC_CHECK_HEADER(jerror.h,
AC_CHECK_LIB(jpeg, jpeg_destroy_compress, HAVE_JPEG=yes))
@@ -2086,7 +2098,7 @@ strerror fpathconf select mktime euidaccess getpagesize tzset setlocale \
utimes setrlimit setpgid getcwd getwd shutdown strftime getaddrinfo \
__fpending mblen mbrlen mbsinit strsignal setitimer ualarm index rindex \
sendto recvfrom getsockopt setsockopt getsockname getpeername \
-gai_strerror mkstemp getline getdelim mremap memmove fsync bzero)
+gai_strerror mkstemp getline getdelim mremap memmove fsync bzero memset)
AC_CHECK_HEADERS(sys/un.h)
@@ -2099,6 +2111,8 @@ AC_FUNC_GETLOADAVG
AC_FUNC_FSEEKO
+AC_FUNC_GETPGRP
+
# UNIX98 PTYs.
AC_CHECK_FUNCS(grantpt)