summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2014-08-10 13:40:57 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2014-08-10 13:40:57 -0700
commitf22bc725a1c8294fc042f6a9541be01a177755f6 (patch)
treec54be44171d43157177e8879d5ec3d583edfe5a1 /configure.ac
parentd5f2feb5818b9da8323bda683983fa7e637c47fd (diff)
downloademacs-f22bc725a1c8294fc042f6a9541be01a177755f6.tar.gz
Don't prevent random file systems from being unmounted.
This fix relies on having the 'fchdir' function, and on having "." be searchable (or at least readable, on platforms lacking O_SEARCH), but that's good enough to handle the vast majority of cases and the remaining folks can just live with the annoyance of file systems that occasionally can't be unmounted. * configure.ac (fchdir): New function to check for. * lib/save-cwd.c: Copy from gnulib, except omit the part that allocates memory, since that can cause problems in Emacs. * lib/save-cwd.h: Copy from gnulib. Fixes: debbugs:18232
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8e74f799ec9..04925d59d22 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3508,7 +3508,7 @@ esac
AC_SUBST(BLESSMAIL_TARGET)
-AC_CHECK_FUNCS(accept4 gethostname \
+AC_CHECK_FUNCS(accept4 fchdir gethostname \
getrusage get_current_dir_name \
lrand48 \
select getpagesize setlocale \