summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2022-12-21 21:52:18 +0200
committerEli Zaretskii <eliz@gnu.org>2022-12-21 21:53:03 +0200
commitc088cdad9e94f905c23783d7d02c6ca44aed8310 (patch)
tree61a79c805a6841b29eae73356a5ad129a6abd1a8 /configure.ac
parentec9fbad908d5f65f71717506d070a40acca89f5b (diff)
downloademacs-c088cdad9e94f905c23783d7d02c6ca44aed8310.tar.gz
Fix the --without-all build with tree-sitter
* configure.ac (HAVE_TREE_SITTER): Set NEED_DYNLIB=yes, since tree-sitter support requires dynlib.o. (Bug#60061)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 432638f8721..ac29f351fb3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3220,6 +3220,7 @@ AC_SUBST([JSON_OBJ])
HAVE_TREE_SITTER=no
TREE_SITTER_OBJ=
+NEED_DYNLIB=no
if test "${with_tree_sitter}" != "no"; then
dnl Tree-sitter 0.20.2 added support to change the malloc it uses
@@ -3245,6 +3246,7 @@ if test "${with_tree_sitter}" != "no"; then
LIBS=$OLD_LIBS
if test "$ac_cv_func_ts_set_allocator" = yes; then
AC_DEFINE(HAVE_TREE_SITTER, 1, [Define if using tree-sitter.])
+ NEED_DYNLIB=yes
else
AC_MSG_ERROR([Tree-sitter library exists but its version is too old]);
TREE_SITTER_CFLAGS=
@@ -4154,7 +4156,6 @@ AC_SUBST(DYNAMIC_LIB_SECONDARY_SUFFIX)
LIBMODULES=
HAVE_MODULES=no
MODULES_OBJ=
-NEED_DYNLIB=no
MODULES_SUFFIX="${DYNAMIC_LIB_SUFFIX}"
MODULES_SECONDARY_SUFFIX="${DYNAMIC_LIB_SECONDARY_SUFFIX}"