summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Kangas <stefankangas@gmail.com>2023-02-13 06:30:12 +0100
committerStefan Kangas <stefankangas@gmail.com>2023-02-13 06:30:12 +0100
commitbf60b3bfe7b42e61f34843d007b4c6df2fe644b5 (patch)
tree6dbfe7372ca5ffe64eac5ca457bc0dbcd6d8788f /configure.ac
parente0b60120a1c3433fe332bff56b5b7483b0424d5c (diff)
parenteb2b0931cf1258b875b031f81a3685eda8ddf5cb (diff)
downloademacs-bf60b3bfe7b42e61f34843d007b4c6df2fe644b5.tar.gz
Merge from origin/emacs-29
eb2b0931cf1 Add lambda_expression to c-ts-common-indent-type-regexp-a... 2da05876edb ; Use the right name when specifying VC packages d4fc7012978 Tolerate missing elpa-packages.eld files 8bc1b7d0b27 Avoid warning about 'load-path' in non-interactive sessions 3d17aee13d9 ; Fix installation of dependencies for VC packages 86ca7df6a34 ; Mention Hunspell private-dictionary misfeature in doc s... 7287b7b53a1 Support webkit2gtk-4.1 048a2dabfc4 ; Fix typo
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7bb0df88cb3..c44165fb5c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3583,8 +3583,12 @@ XWIDGETS_OBJ=
if test "$with_xwidgets" != "no"; then
if test "$USE_GTK_TOOLKIT" = "GTK3" && test "$window_system" != "none"; then
WEBKIT_REQUIRED=2.12
- WEBKIT_MODULES="webkit2gtk-4.0 >= $WEBKIT_REQUIRED"
+ WEBKIT_MODULES="webkit2gtk-4.1 >= $WEBKIT_REQUIRED"
EMACS_CHECK_MODULES([WEBKIT], [$WEBKIT_MODULES])
+ if test "$HAVE_WEBKIT" = "no"; then
+ WEBKIT_MODULES="webkit2gtk-4.0 >= $WEBKIT_REQUIRED"
+ EMACS_CHECK_MODULES([WEBKIT], [$WEBKIT_MODULES])
+ fi
HAVE_XWIDGETS=$HAVE_WEBKIT
XWIDGETS_OBJ="xwidget.o"
if test "$HAVE_X_WINDOWS" = "yes" && test "${with_cairo}" = "no"; then