summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLars Ingebrigtsen <larsi@gnus.org>2019-09-24 19:01:51 +0200
committerLars Ingebrigtsen <larsi@gnus.org>2019-09-24 19:01:51 +0200
commit9a82195cfcafd3003fc971b71ab401b37ecc0930 (patch)
tree14eb0d70b65e10c507b11a713e03704e0ea89b9e /configure.ac
parent873cd63ff2a2fc738664065e84a997fe7b4e7051 (diff)
downloademacs-9a82195cfcafd3003fc971b71ab401b37ecc0930.tar.gz
Make --with-imagemagick bug out if there's no support for it
* configure.ac (HAVE_IMAGEMAGICK): Stop configuration if the user has said --with-imagemagick, but there's no support for it (bug#24455).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e822b0b7b0f..7435f2e8da3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2638,6 +2638,9 @@ if test "${HAVE_X11}" = "yes" || test "${HAVE_NS}" = "yes" || test "${HAVE_W32}"
if test $HAVE_IMAGEMAGICK = yes; then
AC_DEFINE([HAVE_IMAGEMAGICK], 1, [Define to 1 if using ImageMagick.])
else
+ if test "${with_imagemagick}" != "no"; then
+ AC_MSG_ERROR([ImageMagick wanted, but it does not compile. Maybe some library files are missing?]);
+ fi
IMAGEMAGICK_CFLAGS=
IMAGEMAGICK_LIBS=
fi