summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Albinus <michael.albinus@gmx.de>2023-03-26 14:20:05 +0200
committerMichael Albinus <michael.albinus@gmx.de>2023-03-26 14:20:05 +0200
commit8b4a494d8d4413ae6d566f6478f84e319aeaacdd (patch)
treee9a92c453deb6130915d54995ba257de3d469a2e /configure.ac
parenta952bdd6af081ef78f25f20d0a6cde612ce10df0 (diff)
downloademacs-8b4a494d8d4413ae6d566f6478f84e319aeaacdd.tar.gz
Fix GNUSTEP tests on EMBA
* configure.ac (LIBS_GNUSTEP): Adapt CPPFLAGS and CFLAGS. (Bug#62210) Proposed by Po Lu <luangruo@yahoo.com>. * test/infra/gitlab-ci.yml (build-image-gnustep) (test-gnustep): Uncomment jobs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c818343a5ad..aa78c7a16dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2059,8 +2059,8 @@ if test "${with_ns}" != no; then
GNUSTEP_LOCAL_HEADERS="-I${GNUSTEP_LOCAL_HEADERS}"
test "x${GNUSTEP_LOCAL_LIBRARIES}" != "x" && \
GNUSTEP_LOCAL_LIBRARIES="-L${GNUSTEP_LOCAL_LIBRARIES}"
- CPPFLAGS="$CPPFLAGS -I${GNUSTEP_SYSTEM_HEADERS} ${GNUSTEP_LOCAL_HEADERS}"
- CFLAGS="$CFLAGS -I${GNUSTEP_SYSTEM_HEADERS} ${GNUSTEP_LOCAL_HEADERS}"
+ CPPFLAGS="$CPPFLAGS -isystem ${GNUSTEP_SYSTEM_HEADERS} ${GNUSTEP_LOCAL_HEADERS}"
+ CFLAGS="$CFLAGS -isystem ${GNUSTEP_SYSTEM_HEADERS} ${GNUSTEP_LOCAL_HEADERS}"
LDFLAGS="$LDFLAGS -L${GNUSTEP_SYSTEM_LIBRARIES} ${GNUSTEP_LOCAL_LIBRARIES}"
LIBS_GNUSTEP="-lgnustep-gui -lgnustep-base -lobjc -lpthread"
dnl GNUstep defines BASE_NATIVE_OBJC_EXCEPTIONS to 0 or 1.