summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYuan Fu <casouri@gmail.com>2022-11-09 14:48:07 -0800
committerYuan Fu <casouri@gmail.com>2022-11-09 15:51:13 -0800
commit663d768d44be150439a58cd858615cac3c1f572f (patch)
tree7d17de257f8b4989f5d8bff763925d724063b88b /configure.ac
parent838fc77254286de318b65602b31c6d3915594a8e (diff)
downloademacs-663d768d44be150439a58cd858615cac3c1f572f.tar.gz
* configure.ac: Change required tree-sitter version to 0.20.2.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 390838acfe5..c5f2be64399 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3215,11 +3215,9 @@ HAVE_TREE_SITTER=no
TREE_SITTER_OBJ=
if test "${with_tree_sitter}" != "no"; then
- dnl TODO: we should use tree-sitter >= 0.20.2, but right now all
- dnl tree-sitter libraries distributed are versioned at 0.0, so for
- dnl the easy of development we'll just leave the version
- dnl requirement at 0.0 for now.
- EMACS_CHECK_MODULES([TREE_SITTER], [tree-sitter >= 0.0],
+ dnl Tree-sitter 0.20.2 added support to change the malloc it uses
+ dnl at runtime.
+ EMACS_CHECK_MODULES([TREE_SITTER], [tree-sitter >= 0.20.2],
[HAVE_TREE_SITTER=yes], [HAVE_TREE_SITTER=no])
if test "${HAVE_TREE_SITTER}" = yes; then
AC_DEFINE(HAVE_TREE_SITTER, 1, [Define if using tree-sitter.])