summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrea Corallo <akrl@sdf.org>2023-03-15 16:18:04 +0100
committerAndrea Corallo <akrl@sdf.org>2023-03-15 16:20:37 +0100
commit61adb44318a30d599712b69c7e6606510ce0ce2c (patch)
tree7c3ffcd6c541fd343bf87115aaa3c19c104e4f05 /configure.ac
parentd814c249f4431449ed94c2ad1443457fce393c86 (diff)
downloademacs-61adb44318a30d599712b69c7e6606510ce0ce2c.tar.gz
* configure.ac: Fix native comp compatibility check (bug#61960)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ac93d003b70..c818343a5ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4328,8 +4328,8 @@ If you really want to try it anyway, use the configure option
fi
if test "${with_native_compilation}" != "no"; then
- if test "${HAVE_PDUMPER}" = no; then
- AC_MSG_ERROR(['--with-native-compilation' requires '--with-dumping=pdumper'])
+ if test "$with_unexec" = yes; then
+ AC_MSG_ERROR(['--with-native-compilation' is not compatible with unexec])
fi
if test "${HAVE_ZLIB}" = no; then
AC_MSG_ERROR(['--with-native-compilation' requires zlib])