summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Monnier <monnier@iro.umontreal.ca>2023-03-27 17:16:59 -0400
committerStefan Monnier <monnier@iro.umontreal.ca>2023-03-27 17:16:59 -0400
commit47bce04e875bdaf4a9e2bb33dc14794d373b676f (patch)
treed13dae0c30b300e332292f6fb8fd2ce13b500889 /configure.ac
parent2b4e14e3abd5be08ee2a4e832b5dbe8172869e24 (diff)
parent0337131bfa194856234ddfe70ee38b3165d66289 (diff)
downloademacs-47bce04e875bdaf4a9e2bb33dc14794d373b676f.tar.gz
Merge from origin/emacs-29
0337131bfa1 Update to Transient v0.3.7-218-g3dbb22a a8c23677d39 Update to Org 9.6.2 45b16bfb496 Skip failing tests on Cygwin with native compilation (bug... 8b4a494d8d4 Fix GNUSTEP tests on EMBA # Conflicts: # test/infra/gitlab-ci.yml
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 95701b55704..a9a8f10ec21 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2062,8 +2062,8 @@ if test "${with_ns}" != no; then
GNUSTEP_LOCAL_HEADERS="-I${GNUSTEP_LOCAL_HEADERS}"
test "x${GNUSTEP_LOCAL_LIBRARIES}" != "x" && \
GNUSTEP_LOCAL_LIBRARIES="-L${GNUSTEP_LOCAL_LIBRARIES}"
- CPPFLAGS="$CPPFLAGS -I${GNUSTEP_SYSTEM_HEADERS} ${GNUSTEP_LOCAL_HEADERS}"
- CFLAGS="$CFLAGS -I${GNUSTEP_SYSTEM_HEADERS} ${GNUSTEP_LOCAL_HEADERS}"
+ CPPFLAGS="$CPPFLAGS -isystem ${GNUSTEP_SYSTEM_HEADERS} ${GNUSTEP_LOCAL_HEADERS}"
+ CFLAGS="$CFLAGS -isystem ${GNUSTEP_SYSTEM_HEADERS} ${GNUSTEP_LOCAL_HEADERS}"
LDFLAGS="$LDFLAGS -L${GNUSTEP_SYSTEM_LIBRARIES} ${GNUSTEP_LOCAL_LIBRARIES}"
LIBS_GNUSTEP="-lgnustep-gui -lgnustep-base -lobjc -lpthread"
dnl GNUstep defines BASE_NATIVE_OBJC_EXCEPTIONS to 0 or 1.