summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2022-11-03 11:09:53 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2022-11-03 11:10:32 -0700
commit39f5696921c1618f46358a5c189244d3993a1fca (patch)
tree9ed6ee467a52babf68a9eb4899a3a1fa029f51b0 /configure.ac
parent651bf0a99923e5eff279e9f9649aaed3d2f05c71 (diff)
downloademacs-39f5696921c1618f46358a5c189244d3993a1fca.tar.gz
Improve suppression of bogus macOS warnings
* configure.ac: On macOS, always use -Wno-deprecated-declarations, as the false alarms appear even if --disable-gcc-warnings is given (Bug#58966).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index c9d1eb57092..b656dba4d99 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1144,12 +1144,6 @@ AS_IF([test $gl_gcc_warnings = no],
gl_WARN_ADD([-Wno-int-in-bool-context])
fi
- # Suppress deprecation warnings from using sprintf variants,
- # starting with Xcode 14.1 on macOS 13.
- if test $opsys = darwin; then
- gl_WARN_ADD([-Wno-deprecated-declarations])
- fi
-
# This causes too much noise in the MinGW build
if test $opsys = mingw32; then
gl_WARN_ADD([-Wno-pointer-sign])
@@ -1176,6 +1170,13 @@ if test "$emacs_cv_clang" = yes; then
gl_WARN_ADD([-Wno-tautological-constant-out-of-range-compare])
fi
+# Suppress deprecation warnings from using sprintf variants,
+# starting with Xcode 14.1 on macOS 13.
+# These warnings are false alarms, as Emacs usage of sprintf is safe.
+if test $opsys = darwin; then
+ gl_WARN_ADD([-Wno-deprecated-declarations])
+fi
+
# Use a slightly smaller set of warning options for lib/.
nw=
nw="$nw -Wunused-macros"