summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2017-08-02 19:13:26 -0700
committerPaul Eggert <eggert@cs.ucla.edu>2017-08-02 19:15:45 -0700
commit2d2c12fc5f45ff73387efd6241447f3d9cbadf09 (patch)
tree70d541944e89ad83cfaa35dad8b9e15b6faa8d48 /configure.ac
parent5ed0bf1061cb0b2e70ee1d28f5f3586259ec0f3b (diff)
downloademacs-2d2c12fc5f45ff73387efd6241447f3d9cbadf09.tar.gz
Default to --with-mailutils if it is installed
* configure.ac (with_mailutils): Default to 'yes' if GNU Mailutils is installed. See: http://lists.gnu.org/archive/html/emacs-devel/2017-08/msg00054.html
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c3e440adcaa..c9e8c0dd1c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -234,9 +234,16 @@ AC_DEFUN([OPTION_DEFAULT_ON], [dnl
# in a movemail implementation that supports only unencrypted POP3
# connections. Encrypted connections should be the default.
-OPTION_DEFAULT_OFF([mailutils],
- [rely on GNU Mailutils, so that the --without-pop through --with-mailhost
- options are irrelevant])
+AC_ARG_WITH([mailutils],
+ [AS_HELP_STRING([--with-mailutils],
+ [rely on GNU Mailutils, so that the --without-pop through --with-mailhost
+ options are irrelevant; this is the default if GNU Mailutils is
+ installed])],
+ [],
+ [with_mailutils=$with_features
+ if test "$with_mailutils" = yes; then
+ (movemail --version) >/dev/null 2>&1 || with_mailutils=no
+ fi])
if test "$with_mailutils" = no; then
with_mailutils=
fi