summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2023-01-19 15:15:52 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2023-01-19 19:07:33 -0800
commit167bf3408e437704b27171c6fad5d15bbc623b3a (patch)
treee1e16bd25ae95f4016f434ec2e215ed1eff1a99f /configure.ac
parent54d5ea66c99f03240379d6d2e411145cced585a5 (diff)
downloademacs-167bf3408e437704b27171c6fad5d15bbc623b3a.tar.gz
Pacify clang 15.0.6 on Fedora 37
* configure.ac: Suppress clang -Wbitwise-instead-of-logical, as there’s nothing wrong with using & and | on bool. * src/coding.c: Suppress -Wunused-but-set-variable in this file, as it’s too much trouble to recode to pacify clang.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d7aec4414e3..fc17dbd8318 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1139,6 +1139,7 @@ AS_IF([test $gl_gcc_warnings = no],
# clang is unduly picky about some things.
if test "$emacs_cv_clang" = yes; then
+ gl_WARN_ADD([-Wno-bitwise-instead-of-logical])
gl_WARN_ADD([-Wno-missing-braces])
gl_WARN_ADD([-Wno-null-pointer-arithmetic])
gl_WARN_ADD([-Wno-implicit-const-int-float-conversion])