summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Kangas <stefankangas@gmail.com>2022-12-22 06:30:09 +0100
committerStefan Kangas <stefankangas@gmail.com>2022-12-22 06:30:09 +0100
commit08bb91c7df4ebf0dd9de4d55575aaaed87a9b339 (patch)
tree245f7772c6466026384bed6c7f95af1b78235bb3 /configure.ac
parentad5a67996ddf23df904c09165475759e2e0a68b1 (diff)
parente59216d3be86918b995bd63273c851ebc6176a83 (diff)
downloademacs-08bb91c7df4ebf0dd9de4d55575aaaed87a9b339.tar.gz
Merge from origin/emacs-29
e59216d3be8 * Invoke spawed Emacs processes with '-Q' when native com... 777b383dd0f Fix Eshell electric slash when used from the root directo... c088cdad9e9 Fix the --without-all build with tree-sitter ec9fbad908d Fix write-region to null device on MS-Windows f35da111990 message: Do not default to eudc-capf-complete yet 98c16a8c883 ; * lisp/tab-bar.el: Remaining renaming of "fixed-width" ... d76d7a3bebf whitespace: Avoid mutating original buffer's markers in c...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5bd6645a256..6e9b11986c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3222,6 +3222,7 @@ AC_SUBST([JSON_OBJ])
HAVE_TREE_SITTER=no
TREE_SITTER_OBJ=
+NEED_DYNLIB=no
if test "${with_tree_sitter}" != "no"; then
dnl Tree-sitter 0.20.2 added support to change the malloc it uses
@@ -3247,6 +3248,7 @@ if test "${with_tree_sitter}" != "no"; then
LIBS=$OLD_LIBS
if test "$ac_cv_func_ts_set_allocator" = yes; then
AC_DEFINE(HAVE_TREE_SITTER, 1, [Define if using tree-sitter.])
+ NEED_DYNLIB=yes
else
AC_MSG_ERROR([Tree-sitter library exists but its version is too old]);
TREE_SITTER_CFLAGS=
@@ -4145,7 +4147,6 @@ AC_SUBST(DYNAMIC_LIB_SECONDARY_SUFFIX)
LIBMODULES=
HAVE_MODULES=no
MODULES_OBJ=
-NEED_DYNLIB=no
MODULES_SUFFIX="${DYNAMIC_LIB_SUFFIX}"
MODULES_SECONDARY_SUFFIX="${DYNAMIC_LIB_SECONDARY_SUFFIX}"