summaryrefslogtreecommitdiff
path: root/elfutils/libelf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'elfutils/libelf/Makefile.am')
-rw-r--r--elfutils/libelf/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/elfutils/libelf/Makefile.am b/elfutils/libelf/Makefile.am
index f27d4f0b..b93f49c6 100644
--- a/elfutils/libelf/Makefile.am
+++ b/elfutils/libelf/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to create Makefile.in
##
-## Copyright (C) 1996-2001, 2002, 2003, 2004, 2005, 2006 Red Hat, Inc.
+## Copyright (C) 1996-2006, 2007 Red Hat, Inc.
## This file is part of Red Hat elfutils.
##
## Red Hat elfutils is free software; you can redistribute it and/or modify
@@ -107,7 +107,7 @@ libelf_so_SOURCES =
libelf.so: libelf_pic.a libelf.map
$(LINK) -shared -o $@ -Wl,--whole-archive,$<,--no-whole-archive \
-Wl,--version-script,$(srcdir)/libelf.map,--no-undefined \
- -Wl,--soname,$@.$(VERSION),-z,-defs
+ -Wl,--soname,$@.$(VERSION),-z,-defs,-z,relro
if readelf -d $@ | fgrep -q TEXTREL; then exit 1; fi
ln -fs $@ $@.$(VERSION)