summaryrefslogtreecommitdiff
path: root/elfutils/libasm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'elfutils/libasm/Makefile.am')
-rw-r--r--elfutils/libasm/Makefile.am16
1 files changed, 5 insertions, 11 deletions
diff --git a/elfutils/libasm/Makefile.am b/elfutils/libasm/Makefile.am
index 9ba304d1..34b19d24 100644
--- a/elfutils/libasm/Makefile.am
+++ b/elfutils/libasm/Makefile.am
@@ -1,7 +1,6 @@
## Process this file with automake to create Makefile.in
-## Configure input file for elfutils.
##
-## Copyright (C) 2002, 2004 Red Hat, Inc.
+## Copyright (C) 2002, 2004, 2005 Red Hat, Inc.
##
## This program is Open Source software; you can redistribute it and/or
## modify it under the terms of the Open Software License version 1.0 as
@@ -15,17 +14,16 @@
##
DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H
if MUDFLAP
-AM_CFLAGS = -Wall
+AM_CFLAGS = -fmudflap
else
-AM_CFLAGS = -Wall -Werror
+AM_CFLAGS =
endif
+AM_CFLAGS += -Wall -Wshadow -Werror -Wunused -Wextra -Wformat=2
INCLUDES = -I. -I$(srcdir) -I.. -I$(top_srcdir)/libelf -I$(top_srcdir)/libebl \
-I$(top_srcdir)/lib
GCC_INCLUDE = -I$(shell $(CC) -print-file-name=include)
VERSION = 1
-LINT = splint
-
lib_LIBRARIES = libasm.a
if !MUDFLAP
noinst_LIBRARIES = libasm_pic.a
@@ -57,6 +55,7 @@ libasm.so: libasm_pic.a libasm.map
-Wl,--version-script,$(srcdir)/libasm.map,--no-undefined \
-Wl,--soname,$@.$(VERSION) \
../libebl/libebl.a ../libelf/libelf.so
+ if readelf -d $@ | fgrep -q TEXTREL; then exit 1; fi
ln -fs $@ $@.$(VERSION)
@@ -81,11 +80,6 @@ uninstall: uninstall-am
rmdir --ignore-fail-on-non-empty $(DESTDIR)$(includedir)/elfutils
endif
-.PSEUDO: lint
-lint:
- $(LINT) $(DEFS) $(INCLUDES) $(GCC_INCLUDE) -f $(top_srcdir)/splint.rc \
- $(addprefix $(srcdir)/,$(libelf_la_SOURCES))
-
noinst_HEADERS = libasmP.h symbolhash.h
EXTRA_DIST = libasm.map