summaryrefslogtreecommitdiff
path: root/elfutils/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'elfutils/lib/Makefile.am')
-rw-r--r--elfutils/lib/Makefile.am20
1 files changed, 9 insertions, 11 deletions
diff --git a/elfutils/lib/Makefile.am b/elfutils/lib/Makefile.am
index 43a13582..facb5634 100644
--- a/elfutils/lib/Makefile.am
+++ b/elfutils/lib/Makefile.am
@@ -1,7 +1,6 @@
## Process this file with automake to create Makefile.in
-## Configure input file for elfutils.
##
-## Copyright (C) 1996-2001, 2002, 2004 Red Hat, Inc.
+## Copyright (C) 1996-2001, 2002, 2004, 2005 Red Hat, Inc.
##
## This program is free software; you can redistribute it and/or modify
## it under the terms of the GNU General Public License as published by
@@ -17,21 +16,20 @@
## Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
##
DEFS = -D_GNU_SOURCE -DHAVE_CONFIG_H
-AM_CFLAGS = -Wall $(if $($(*F)_no_Werror),,-Werror) $(picflag)
-if !MUDFLAP
-picflag = -fpic
+if MUDFLAP
+AM_CFLAGS = -fmudflap
+else
+AM_CFLAGS =
endif
+AM_CFLAGS += -fpic -Wall -Wshadow -Werror -Wunused -Wextra $($(*F)_CFLAGS)
INCLUDES = -I$(srcdir)/../libelf -I..
noinst_LIBRARIES = libeu.a
-libeu_a_SOURCES = xstrdup.c xstrndup.c xmalloc.c next_prime.c crc32.c
+libeu_a_SOURCES = xstrdup.c xstrndup.c xmalloc.c next_prime.c \
+ crc32.c crc32_file.c
noinst_HEADERS = fixedsizehash.h system.h dynamicsizehash.h list.h
EXTRA_DIST = dynamicsizehash.c
-# XXX gcc has a bug in that it generates warnings for internal symbols.
-if MUDFLAP
-xmalloc_no_Werror = yes
-crc32_no_Werror = yes
-endif
+xmalloc_CFLAGS = -ffunction-sections