summaryrefslogtreecommitdiff
path: root/elfutils/elfutils.spec
diff options
context:
space:
mode:
Diffstat (limited to 'elfutils/elfutils.spec')
-rw-r--r--elfutils/elfutils.spec71
1 files changed, 44 insertions, 27 deletions
diff --git a/elfutils/elfutils.spec b/elfutils/elfutils.spec
index e4f18b10..29462ff1 100644
--- a/elfutils/elfutils.spec
+++ b/elfutils/elfutils.spec
@@ -1,7 +1,7 @@
# -*- rpm-spec-*-
Summary: A collection of utilities and DSOs to handle compiled objects
Name: elfutils
-Version: 0.152
+Version: 0.153
Release: 1
License: GPLv2 with exceptions
Group: Development/Tools
@@ -9,6 +9,7 @@ Source: elfutils-%{version}.tar.bz2
Obsoletes: libelf libelf-devel
Requires: elfutils-libelf = %{version}-%{release}
Requires: glibc >= 2.7
+Requires: libstdc++
# ExcludeArch: xxx
@@ -23,6 +24,7 @@ BuildRequires: gettext
BuildRequires: zlib-devel
BuildRequires: bzip2-devel
BuildRequires: xz-devel
+BuildRequires: gcc-c++
%define _gnu %{nil}
%define _programprefix eu-
@@ -188,12 +190,27 @@ rm -rf ${RPM_BUILD_ROOT}
%{_libdir}/libelf.a
%changelog
+* Thu Feb 23 2012 Mark Wielaard <mjw@redhat.com> 0.153-1
+- libdw: Support reading .zdebug_* DWARF sections compressed via zlib.
+- libdwfl: Speed up dwfl_module_addrsym.
+- nm: Support C++ demangling.
+- ar: Support D modifier for "deterministic output" with no
+ uid/gid/mtime info. The U modifier is the inverse. elfutils
+ can be configured with the --enable-deterministic-archives option
+ to make the D behavior the default when U is not specified.
+- ranlib: Support -D and -U flags with same meaning.
+- readelf: Improve output of -wline. Add support for printing SDT elf
+ notes. Add printing of .gdb_index section. Support for
+ typed DWARF stack, call_site and entry_value.
+- strip: Add --reloc-debug-sections option. Improved SHT_GROUP
+ sections handling.
+
* Tue Feb 15 2011 <drepper@gmail.com> 0.152-1
- Various build and warning nits fixed for newest GCC and Autoconf.
-- libdwfl: Yet another prelink-related fix for another regression.
- Look for Linux kernel images in files named with compression
+- libdwfl: Yet another prelink-related fix for another regression.
+ Look for Linux kernel images in files named with compression
suffixes.
-- elfcmp: New flag --ignore-build-id to ignore differing build ID
+- elfcmp: New flag --ignore-build-id to ignore differing build ID
bits. New flag -l/--verbose to print all differences.
* Wed Jan 12 2011 <drepper@gmail.com> 0.151-1
@@ -204,23 +221,23 @@ rm -rf ${RPM_BUILD_ROOT}
- libdw: Fix for handling huge .debug_aranges section.
- libdwfl: Fix for handling prelinked DSO with separate debug file.
- findtextrel: Fix diagnostics to work with usual section ordering.
-- libebl: i386 backend fix for multi-register integer return value
+- libebl: i386 backend fix for multi-register integer return value
location.
* Mon Sep 13 2010 <drepper@redhat.com> 0.149-1
-- libdw: Decode new DW_OP_GNU_implicit_pointer operation; new
+- libdw: Decode new DW_OP_GNU_implicit_pointer operation; new
function dwarf_getlocation_implicit_pointer.
- libdwfl: New function dwfl_dwarf_line.
-- addr2line: New flag -F/--flags to print more DWARF line information
+- addr2line: New flag -F/--flags to print more DWARF line information
details.
- strip: -g recognizes .gdb_index as a debugging section.
* Mon Jun 28 2010 <drepper@redhat.com> 0.148-1
-- libdw: Accept DWARF 4 format: new functions dwarf_next_unit,
- dwarf_offdie_types. New functions dwarf_lineisa,
+- libdw: Accept DWARF 4 format: new functions dwarf_next_unit,
+ dwarf_offdie_types. New functions dwarf_lineisa,
dwarf_linediscriminator, dwarf_lineop_index.
-- libdwfl: Fixes in core-file handling, support cores from PIEs.
- When working from build IDs, don't open a named file that
+- libdwfl: Fixes in core-file handling, support cores from PIEs.
+ When working from build IDs, don't open a named file that
mismatches.
- readelf: Handle DWARF 4 formats.
@@ -238,26 +255,26 @@ rm -rf ${RPM_BUILD_ROOT}
- Fix build with most recent glibc headers.
- libelf: More robust to bogus section headers.
- libdw: Fix CFI decoding.
-- libdwfl: Fix address bias returned by CFI accessors. Fix core
+- libdwfl: Fix address bias returned by CFI accessors. Fix core
file module layout identification.
- readelf: Fix CFI decoding.
* Thu Jan 14 2010 <drepper@redhat.com> 0.144-1
-- libelf: New function elf_getphdrnum. Now support using more than
+- libelf: New function elf_getphdrnum. Now support using more than
65536 program headers in a file.
-- libdw: New function dwarf_aggregate_size for computing (constant)
- type sizes, including array_type cases with nontrivial
+- libdw: New function dwarf_aggregate_size for computing (constant)
+ type sizes, including array_type cases with nontrivial
calculation.
-- readelf: Don't give errors for missing info under -a.
+- readelf: Don't give errors for missing info under -a.
Handle Linux "VMCOREINFO" notes under -n.
* Mon Sep 21 2009 <drepper@redhat.com> 0.143-1
-- libdw: Various convenience functions for individual attributes now
- use dwarf_attr_integrate to look up indirect inherited
- attributes. Location expression handling now supports
+- libdw: Various convenience functions for individual attributes now
+ use dwarf_attr_integrate to look up indirect inherited
+ attributes. Location expression handling now supports
DW_OP_implicit_value.
-- libdwfl: Support automatic decompression of files in XZ format,
- and of Linux kernel images made with bzip2 or LZMA (as well
+- libdwfl: Support automatic decompression of files in XZ format,
+ and of Linux kernel images made with bzip2 or LZMA (as well
as gzip).
* Mon Jun 29 2009 <drepper@redhat.com> 0.142-1
@@ -269,25 +286,25 @@ rm -rf ${RPM_BUILD_ROOT}
- readelf: Add -N option, speeds up DWARF printing without address->name lookups.
- libdw: Add support for decoding DWARF CFI into location description form.
Handle some new DWARF 3 expression operations previously omitted.
- Basic handling of some new encodings slated for DWARF
+ Basic handling of some new encodings slated for DWARF
* Thu Apr 23 2009 Ulrich Drepper <drepper@redhat.com> 0.141-1
- libebl: sparc backend fixes; some more arm backend support
-- libdwfl: fix dwfl_module_build_id for prelinked DSO case;
- fixes in core file support; dwfl_module_getsym interface
+- libdwfl: fix dwfl_module_build_id for prelinked DSO case;
+ fixes in core file support; dwfl_module_getsym interface
improved for non-address symbols
- strip: fix infinite loop on strange inputs with -f
-- addr2line: take -j/--section=NAME option for binutils compatibility
+- addr2line: take -j/--section=NAME option for binutils compatibility
(same effect as '(NAME)0x123' syntax already supported)
* Mon Feb 16 2009 Ulrich Drepper <drepper@redhat.com> 0.140-1
- libelf: Fix regression in creation of section header
-- libdwfl: Less strict behavior if DWARF reader ist just used to
+- libdwfl: Less strict behavior if DWARF reader ist just used to
display data
* Thu Jan 22 2009 Ulrich Drepper <drepper@redhat.com> 0.139-1
- libcpu: Add Intel SSE4 disassembler support
-- readelf: Implement call frame information and exception handling
+- readelf: Implement call frame information and exception handling
dumping. Add -e option. Enable it implicitly for -a.
- elflint: Check PT_GNU_EH_FRAME program header entry.
- libdwfl: Support automatic gzip/bzip2 decompression of ELF files.