summaryrefslogtreecommitdiff
path: root/libc/sysdeps/i386/elf/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'libc/sysdeps/i386/elf/configure.in')
-rw-r--r--libc/sysdeps/i386/elf/configure.in6
1 files changed, 2 insertions, 4 deletions
diff --git a/libc/sysdeps/i386/elf/configure.in b/libc/sysdeps/i386/elf/configure.in
index ca607adeb..0c436f3f4 100644
--- a/libc/sysdeps/i386/elf/configure.in
+++ b/libc/sysdeps/i386/elf/configure.in
@@ -1,7 +1,6 @@
GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
# Local configure fragment for sysdeps/i386/elf.
-if test "$usetls" != no; then
# Check for support of thread-local storage handling in assembler and
# linker.
AC_CACHE_CHECK(for i386 TLS support, libc_cv_386_tls, [dnl
@@ -28,9 +27,8 @@ else
libc_cv_386_tls=no
fi
rm -f conftest*])
-if test $libc_cv_386_tls = yes; then
- AC_DEFINE(HAVE_TLS_SUPPORT)
-fi
+if test $libc_cv_386_tls = no; then
+ AC_MSG_ERROR([the assembler must support TLS])
fi
dnl It is always possible to access static and hidden symbols in an