summaryrefslogtreecommitdiff
path: root/libc/ports/sysdeps/unix/sysv/linux/m68k
diff options
context:
space:
mode:
authorjoseph <joseph@7b3dc134-2b1b-0410-93df-9e9f96275f8d>2012-08-17 19:39:53 +0000
committerjoseph <joseph@7b3dc134-2b1b-0410-93df-9e9f96275f8d>2012-08-17 19:39:53 +0000
commite7a9915190f0e2b940e4af9ad480cbe035a197d6 (patch)
tree1f2af18154d7414f0ac2204709a0488505bae848 /libc/ports/sysdeps/unix/sysv/linux/m68k
parentdd3105b347f432016fcdc1abd472c3717f557c9e (diff)
downloadeglibc2-e7a9915190f0e2b940e4af9ad480cbe035a197d6.tar.gz
Merge changes between r19920 and r20213 from /fsf/trunk.
git-svn-id: svn://svn.eglibc.org/trunk@20214 7b3dc134-2b1b-0410-93df-9e9f96275f8d
Diffstat (limited to 'libc/ports/sysdeps/unix/sysv/linux/m68k')
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/m68k/coldfire/nptl/bits/atomic.h12
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/m68k/configure1
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/m68k/configure.in1
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/m68k/getrlimit.c1
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/m68k/kernel-features.h9
-rw-r--r--libc/ports/sysdeps/unix/sysv/linux/m68k/vfork.S23
6 files changed, 9 insertions, 38 deletions
diff --git a/libc/ports/sysdeps/unix/sysv/linux/m68k/coldfire/nptl/bits/atomic.h b/libc/ports/sysdeps/unix/sysv/linux/m68k/coldfire/nptl/bits/atomic.h
index b088a7247..23ef447ff 100644
--- a/libc/ports/sysdeps/unix/sysv/linux/m68k/coldfire/nptl/bits/atomic.h
+++ b/libc/ports/sysdeps/unix/sysv/linux/m68k/coldfire/nptl/bits/atomic.h
@@ -1,4 +1,4 @@
-/* Copyright (C) 2010 Free Software Foundation, Inc.
+/* Copyright (C) 2010-2012 Free Software Foundation, Inc.
This file is part of the GNU C Library.
Contributed by Maxim Kuvyrkov <maxim@codesourcery.com>, 2010.
@@ -42,8 +42,8 @@ typedef uintmax_t uatomic_max_t;
#ifdef SHARED
# define atomic_compare_and_exchange_val_acq(mem, newval, oldval) \
({ \
- /* Use temporary variables to workaround call-clobberness of */ \
- /* the registers. */ \
+ /* Use temporary variables to workaround call-clobberness of \
+ the registers. */ \
__typeof (mem) _mem = mem; \
__typeof (oldval) _oldval = oldval; \
__typeof (newval) _newval = newval; \
@@ -65,13 +65,13 @@ typedef uintmax_t uatomic_max_t;
#else
# define atomic_compare_and_exchange_val_acq(mem, newval, oldval) \
({ \
- /* Use temporary variables to workaround call-clobberness of */ \
- /* the registers. */ \
+ /* Use temporary variables to workaround call-clobberness of \
+ the registers. */ \
__typeof (mem) _mem = mem; \
__typeof (oldval) _oldval = oldval; \
__typeof (newval) _newval = newval; \
register __typeof (oldval) _d0 asm ("d0") \
- = SYS_ify (atomic_cmpxchg_32); \
+ = (__typeof (oldval)) SYS_ify (atomic_cmpxchg_32); \
register __typeof (mem) _a0 asm ("a0") = _mem; \
register __typeof (oldval) _d2 asm ("d2") = _oldval; \
register __typeof (newval) _d1 asm ("d1") = _newval; \
diff --git a/libc/ports/sysdeps/unix/sysv/linux/m68k/configure b/libc/ports/sysdeps/unix/sysv/linux/m68k/configure
index a2fd83332..a704dacee 100644
--- a/libc/ports/sysdeps/unix/sysv/linux/m68k/configure
+++ b/libc/ports/sysdeps/unix/sysv/linux/m68k/configure
@@ -1,7 +1,6 @@
# This file is generated from configure.in by Autoconf. DO NOT EDIT!
case $machine in
m68k/coldfire)
- arch_minimum_kernel=2.6.10
;;
*)
libc_cv_gcc_unwind_find_fde=yes
diff --git a/libc/ports/sysdeps/unix/sysv/linux/m68k/configure.in b/libc/ports/sysdeps/unix/sysv/linux/m68k/configure.in
index 6e91ef96f..c21ca9dd4 100644
--- a/libc/ports/sysdeps/unix/sysv/linux/m68k/configure.in
+++ b/libc/ports/sysdeps/unix/sysv/linux/m68k/configure.in
@@ -2,7 +2,6 @@ sinclude(./aclocal.m4)dnl Autoconf lossage
GLIBC_PROVIDES dnl See aclocal.m4 in the top level source directory.
case $machine in
m68k/coldfire)
- arch_minimum_kernel=2.6.10
;;
*)
libc_cv_gcc_unwind_find_fde=yes
diff --git a/libc/ports/sysdeps/unix/sysv/linux/m68k/getrlimit.c b/libc/ports/sysdeps/unix/sysv/linux/m68k/getrlimit.c
deleted file mode 100644
index fc06dbd64..000000000
--- a/libc/ports/sysdeps/unix/sysv/linux/m68k/getrlimit.c
+++ /dev/null
@@ -1 +0,0 @@
-#include <sysdeps/unix/sysv/linux/i386/getrlimit.c>
diff --git a/libc/ports/sysdeps/unix/sysv/linux/m68k/kernel-features.h b/libc/ports/sysdeps/unix/sysv/linux/m68k/kernel-features.h
index 6fb37a616..5c68d7f1c 100644
--- a/libc/ports/sysdeps/unix/sysv/linux/m68k/kernel-features.h
+++ b/libc/ports/sysdeps/unix/sysv/linux/m68k/kernel-features.h
@@ -20,15 +20,10 @@
/* These features were surely available with 2.4.12. */
#define __ASSUME_MMAP2_SYSCALL 1
#define __ASSUME_STAT64_SYSCALL 1
-#define __ASSUME_FCNTL64 1
-#define __ASSUME_VFORK_SYSCALL 1
/* Many syscalls were added in 2.6.10 for m68k. */
-#if __LINUX_KERNEL_VERSION >= 132618
-# define __ASSUME_TGKILL 1
-# define __ASSUME_UTIMES 1
-# define __ASSUME_FADVISE64_64_SYSCALL 1
-#endif
+#define __ASSUME_UTIMES 1
+#define __ASSUME_FADVISE64_64_SYSCALL 1
#include_next <kernel-features.h>
diff --git a/libc/ports/sysdeps/unix/sysv/linux/m68k/vfork.S b/libc/ports/sysdeps/unix/sysv/linux/m68k/vfork.S
index 24e0c9037..d3e20d406 100644
--- a/libc/ports/sysdeps/unix/sysv/linux/m68k/vfork.S
+++ b/libc/ports/sysdeps/unix/sysv/linux/m68k/vfork.S
@@ -36,8 +36,6 @@
ENTRY (__vfork)
-#ifdef __NR_vfork
-
/* SAVE_PID clobbers call-clobbered registers and
saves data in D1 and A1. */
@@ -66,27 +64,8 @@ ENTRY (__vfork)
cfi_adjust_cfa_offset (4)
cfi_rel_offset (%pc, 0)
-# ifdef __ASSUME_VFORK_SYSCALL
-# ifndef PIC
+#ifndef PIC
jbra SYSCALL_ERROR_LABEL
-# endif
-# else
- /* Check if vfork syscall is known at all. */
- movel #-ENOSYS,%d1
- cmpl %d0,%d1
- jne SYSCALL_ERROR_LABEL
-
-# endif
-#endif
-
-#ifndef __ASSUME_VFORK_SYSCALL
- /* If we don't have vfork, fork is close enough. */
-
- movel #SYS_ify (fork), %d0
- trap #0
- tstl %d0
- jmi SYSCALL_ERROR_LABEL
- rts
#endif
PSEUDO_END (__vfork)