summaryrefslogtreecommitdiff
path: root/libc/configure.in
diff options
context:
space:
mode:
authorjoseph <joseph@7b3dc134-2b1b-0410-93df-9e9f96275f8d>2013-07-03 19:45:29 +0000
committerjoseph <joseph@7b3dc134-2b1b-0410-93df-9e9f96275f8d>2013-07-03 19:45:29 +0000
commite82a195fdeb7d40d392e9733b45f443f11fc7424 (patch)
treea9d32f5b54fe6a084b33a2e5b4c245152dde8970 /libc/configure.in
parent46062ca8edd487299e9c317b53598d973bce7c7f (diff)
downloadeglibc2-e82a195fdeb7d40d392e9733b45f443f11fc7424.tar.gz
Merge changes between r23421 and r23438 from /fsf/trunk.
git-svn-id: svn://svn.eglibc.org/trunk@23439 7b3dc134-2b1b-0410-93df-9e9f96275f8d
Diffstat (limited to 'libc/configure.in')
-rw-r--r--libc/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/libc/configure.in b/libc/configure.in
index 2a7d5faa0..d1f0bf348 100644
--- a/libc/configure.in
+++ b/libc/configure.in
@@ -184,6 +184,15 @@ if test "$enable_stackguard_randomize" = yes; then
AC_DEFINE(ENABLE_STACKGUARD_RANDOMIZE)
fi
+AC_ARG_ENABLE([lock-elision],
+ AC_HELP_STRING([--enable-lock-elision[=yes/no]],
+ [Enable lock elision for pthread mutexes and rwlocks by default]),
+ [enable_lock_elision=$enableval],
+ [enable_lock_elision=no])
+if test "$enable_lock_elision" = yes ; then
+ AC_DEFINE(ENABLE_LOCK_ELISION)
+fi
+
dnl Generic infrastructure for drop-in additions to libc.
AC_ARG_ENABLE([add-ons],
AC_HELP_STRING([--enable-add-ons@<:@=DIRS...@:>@],