summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@imgtec.com>2018-01-26 16:21:30 +0000
committerEric Engestrom <eric.engestrom@imgtec.com>2018-01-29 15:41:52 +0000
commitee47329bef727a109418f7134638e0fe67210748 (patch)
tree076307c0601452c83752525a3b7c98dd0c0e3bfe /meson.build
parent540827cc7da2228ae54947adcbf33555a48d0b1c (diff)
downloaddrm-ee47329bef727a109418f7134638e0fe67210748.tar.gz
meson,configure: always define HAVE_{INTEL,VMWGFX,NOUVEAU,EXYNOS,VC4,RADEON}
Signed-off-by: Eric Engestrom <eric.engestrom@imgtec.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index fa00254b..7298f741 100644
--- a/meson.build
+++ b/meson.build
@@ -256,9 +256,7 @@ foreach t : [[with_intel, 'INTEL'], [with_vmwgfx, 'VMWGFX'],
[with_exynos, 'EXYNOS'],
[with_vc4, 'VC4'],
[with_radeon, 'RADEON']]
- if t[0]
- config.set10('HAVE_@0@'.format(t[1]), true)
- endif
+ config.set10('HAVE_@0@'.format(t[1]), t[0])
endforeach
if with_freedreno_kgsl
if not with_freedreno