summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-09-08 09:14:20 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-02-10 14:58:52 +0000
commit332809f3ee19f07abc03b62d5892fae51b9d9902 (patch)
tree15e062c0c4da4b06b36612e7165f1ccbc1caceb8 /meson.build
parentc6d6dce99fb3e7e681fbba9e198345fdbd10e49e (diff)
downloaddrm-332809f3ee19f07abc03b62d5892fae51b9d9902.tar.gz
meson: drop pthread-stubs dependency on BSDs
pthread-stubs >= 0.4 simply passes -pthread which is similar to what dependency('threads') returns. And make it a private dependency for subprojects even on Linux. Reviewed-by: Emmanuel Vadot <manu@FreeBSD.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 0 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 8dcacb94..3c2e171d 100644
--- a/meson.build
+++ b/meson.build
@@ -40,11 +40,6 @@ with_freedreno_kgsl = get_option('freedreno-kgsl')
with_install_tests = get_option('install-test-programs')
with_tests = get_option('tests')
-if ['freebsd', 'dragonfly', 'netbsd'].contains(host_machine.system())
- dep_pthread_stubs = dependency('pthread-stubs', version : '>= 0.4')
-else
- dep_pthread_stubs = []
-endif
dep_threads = dependency('threads')
cc = meson.get_compiler('c')