summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-11-11 23:51:04 +0000
committerEric Engestrom <eric@engestrom.ch>2020-01-23 16:55:04 +0000
commit077e64292cd08bcd84d78b0d5e33bb0fc0cd4078 (patch)
tree16a4dc5f69f3889c86ef8c7bb3e67f4244431cdd /meson.build
parent07d48a4c00ac7944ee066384121e2a00d2b94e30 (diff)
downloaddrm-077e64292cd08bcd84d78b0d5e33bb0fc0cd4078.tar.gz
meson: add symbols check for core libdrm
All the libdrm_* submodules have symbols checks, no reason to keep core libdrm wild. Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Acked-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 782b1a39..4468ac3d 100644
--- a/meson.build
+++ b/meson.build
@@ -305,6 +305,16 @@ libdrm = shared_library(
install : true,
)
+test(
+ 'core-symbols-check',
+ symbols_check,
+ args : [
+ '--lib', libdrm,
+ '--symbols-file', files('core-symbols.txt'),
+ '--nm', prog_nm.path(),
+ ],
+)
+
ext_libdrm = declare_dependency(
link_with : libdrm,
include_directories : [inc_root, inc_drm],