summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2009-11-21 17:45:33 +0100
committerJim Meyering <meyering@redhat.com>2009-11-22 17:16:25 +0100
commite58efa5bd2f2fdab0aff6395b9d6c46e0db09fd3 (patch)
tree39e00ddc0416b7163661be5ab1fbdf2151f4f0d8 /configure.ac
parent8c3d25a63a2c5912170ef6e13f748f3904e6b5cf (diff)
downloaddiffutils-e58efa5bd2f2fdab0aff6395b9d6c46e0db09fd3.tar.gz
build: enable warnings and -Werror.
* src/Makefile.am (AM_CFLAGS): Enable warnings and -Werror. Set to this: $(WARN_CFLAGS) $(WERROR_CFLAGS) * lib/Makefile.am (AM_CFLAGS): Similarly, but use this: $(GNULIB_WARN_CFLAGS) $(WERROR_CFLAGS) * configure.ac (GNULIB_WARN_CFLAGS): Don't turn off -Wuninitialized.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 0 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 044237b..48f30b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,7 +115,6 @@ if test "$gl_gcc_warnings" = yes; then
# We use a slightly smaller set of warning options for lib/.
# Remove the following and save the result in GNULIB_WARN_CFLAGS.
nw=
- nw="$nw -Wuninitialized"
nw="$nw -Wunused-macros"
nw="$nw -Wmissing-prototypes"
nw="$nw -Wold-style-definition"