summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@fb.com>2016-03-15 10:38:23 -0700
committerJim Meyering <meyering@fb.com>2016-03-15 10:38:23 -0700
commit5a485511d77a23d144a05266482ce89171249156 (patch)
treeafded22a1be154b6fe01b7e5ac2388b7d4c1f72f /Makefile.am
parent17e2698bcbee30a6cc282d61ad6242a64ba9c7cf (diff)
downloaddiffutils-5a485511d77a23d144a05266482ce89171249156.tar.gz
maint: don't ignore gitlog-to-changelog failure
* Makefile.am (gen-ChangeLog): Don't ignore failure of gitlog-to-changelog. This syncs to coreutils' copy of this rule.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 06ce7c4..244024e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,9 +34,9 @@ gen_start_date = '2009-11-11 15:00'
gen-ChangeLog:
$(AM_V_GEN)if test -d .git; then \
$(top_srcdir)/build-aux/gitlog-to-changelog \
- --since=$(gen_start_date) > $(distdir)/cl-t; \
- rm -f $(distdir)/ChangeLog; \
- mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ --since=$(gen_start_date) > $(distdir)/cl-t && \
+ { rm -f $(distdir)/ChangeLog && \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; } \
fi
ALL_RECURSIVE_TARGETS += distcheck-hook