summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVincent Untz <vuntz@gnome.org>2011-06-14 14:58:56 +0200
committerVincent Untz <vuntz@gnome.org>2011-06-14 14:58:56 +0200
commit7867a669ffb7d6f50f59b4c9e16b062c6883ce26 (patch)
tree95a2612366bdf58c02bd142942a2b4bbd82bfb74 /configure.ac
parent47322e554cc5388a3e6325f36b7d07a13f124594 (diff)
downloaddesktop-file-utils-7867a669ffb7d6f50f59b4c9e16b062c6883ce26.tar.gz
build: Modernize build system a bit
Do not use libtool as there's nothing needing it. Use the tar-ustar option for AM_INIT_AUTOMAKE for better tarballs. Correctly use ACLOCAL_FLAGS in Makefile.am instead of configure.ac. Do not use AM_MAINTAINER_MODE as it is not recommended by automake developers. Do not use AC_ISC_POSIX nor AC_HEADER_STDC as they shouldn't be needed on modern systems.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 1 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 264d68b..975c6c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,20 +2,12 @@ AC_INIT([desktop-file-utils], [0.19],
[https://bugs.freedesktop.org/enter_bug.cgi?product=desktop-file-utils])
AC_CONFIG_SRCDIR(src/validate.h)
-AM_INIT_AUTOMAKE([1.9 foreign no-dist-gzip dist-bzip2])
+AM_INIT_AUTOMAKE([1.9 foreign no-dist-gzip dist-bzip2 tar-ustar])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
AC_CONFIG_MACRO_DIR([m4])
AM_CONFIG_HEADER(config.h)
-# Honor aclocal flags
-AC_SUBST(ACLOCAL_AMFLAGS, "\${ACLOCAL_FLAGS}")
-
-AM_MAINTAINER_MODE
-
AC_PROG_CC
-AC_ISC_POSIX
-AC_HEADER_STDC
-AM_PROG_LIBTOOL
if test "x$GCC" = "xyes"; then
changequote(,)dnl