summaryrefslogtreecommitdiff
path: root/common/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/common/meson.build b/common/meson.build
index befa9bc..e736ea8 100644
--- a/common/meson.build
+++ b/common/meson.build
@@ -15,18 +15,19 @@ sources = files(
'dconf-changeset.c',
'dconf-error.c',
'dconf-paths.c',
+ 'dconf-gvdb-utils.c',
)
libdconf_common = static_library(
'dconf-common',
sources: sources,
include_directories: top_inc,
- dependencies: glib_dep,
+ dependencies: [glib_dep, libgvdb_dep],
c_args: dconf_c_args,
pic: true,
)
libdconf_common_dep = declare_dependency(
- dependencies: glib_dep,
+ dependencies: [glib_dep, libgvdb_dep],
link_with: libdconf_common,
)