summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-11-12 11:30:48 +0100
committerIñigo Martínez <inigomartinez@gmail.com>2018-08-11 22:55:53 +0200
commitaf3f39dae005c8c3ceb0a88c38b1c2172b20f1d7 (patch)
tree16f292e77a71bbbac72412f7bbdecad3521e1c15 /meson.build
parent5a75f4d0d178e3035a69e2628dc575e9bc80cf98 (diff)
downloaddconf-af3f39dae005c8c3ceb0a88c38b1c2172b20f1d7.tar.gz
build: Rename build options
Following the new meson porting guidelines, this patch renames the build options. The list of changes is as follows: - Remove the enable prefix from boolean options. - Remove the with prefix from string options. - The character separator from multi-word options has been changed to underscore.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7f9767e..68e4e57 100644
--- a/meson.build
+++ b/meson.build
@@ -78,7 +78,7 @@ gio_unix_dep = dependency('gio-unix-2.0', version: gio_unix_req_version)
gio_querymodules = find_program('gio-querymodules', required: false)
if gio_querymodules.found()
- gio_modules_dir = get_option('with-gio-modules-dir').strip()
+ gio_modules_dir = get_option('gio_modules_dir')
if gio_modules_dir == ''
gio_modules_dir = join_paths(dconf_libdir, 'gio', 'modules')
endif