summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPhilip Withnall <withnall@endlessm.com>2018-08-09 17:45:40 +0100
committerPhilip Withnall <withnall@endlessm.com>2018-08-10 14:25:12 +0100
commit0b74acedb5fcf3621c33da014cf944047499b9cf (patch)
tree89220c33e63ce4aa3e9ff52474b6dbfdc2fae46f /meson.build
parent637c54a0195baa1756c338131327e4d593578375 (diff)
downloaddconf-0b74acedb5fcf3621c33da014cf944047499b9cf.tar.gz
tests: Set G_DEBUG and other useful environment variables
Signed-off-by: Philip Withnall <withnall@endlessm.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index af4699a..7f9767e 100644
--- a/meson.build
+++ b/meson.build
@@ -91,6 +91,12 @@ configure_file(
configuration: config_h
)
+test_env = [
+ 'G_DEBUG=gc-friendly,fatal-warnings',
+ 'MALLOC_CHECK_=2',
+ 'LC_ALL=C.UTF-8',
+]
+
gnome = import('gnome')
pkg = import('pkgconfig')