summaryrefslogtreecommitdiff
path: root/test/name-test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/name-test/CMakeLists.txt')
-rw-r--r--test/name-test/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/test/name-test/CMakeLists.txt b/test/name-test/CMakeLists.txt
index dabf892a..32f060a2 100644
--- a/test/name-test/CMakeLists.txt
+++ b/test/name-test/CMakeLists.txt
@@ -6,8 +6,12 @@ add_helper_executable(test-autolaunch test-autolaunch.c dbus-testutils)
add_helper_executable(test-privserver-client test-privserver-client.c dbus-testutils)
add_session_test_executable(test-ids test-ids.c ${DBUS_INTERNAL_LIBRARIES})
-add_session_test_executable(test-pending-call-dispatch test-pending-call-dispatch.c ${DBUS_INTERNAL_LIBRARIES})
-add_session_test_executable(test-pending-call-timeout test-pending-call-timeout.c ${DBUS_INTERNAL_LIBRARIES})
+if (ENABLE_TRADITIONAL_ACTIVATION)
+ add_session_test_executable(test-pending-call-dispatch test-pending-call-dispatch.c ${DBUS_INTERNAL_LIBRARIES})
+ add_session_test_executable(test-pending-call-timeout test-pending-call-timeout.c ${DBUS_INTERNAL_LIBRARIES})
+endif()
add_session_test_executable(test-shutdown test-shutdown.c dbus-testutils)
-add_session_test_executable(test-thread-init test-threads-init.c ${DBUS_INTERNAL_LIBRARIES})
+if (ENABLE_TRADITIONAL_ACTIVATION)
+ add_session_test_executable(test-thread-init test-threads-init.c ${DBUS_INTERNAL_LIBRARIES})
+endif()
endif()